pycharm - 在检查PyCharm时,错误的python版本

但是在我的代码中,我得到了错误:" Python version 3.5 does not support a'F'prefix "

系统中没有Python3.5,我尝试解决:

  • 在pycharm设置中删除了解释器,然后重新添加,
  • 已卸载所有其他python版本,从Windows注册表等中删除了它们的条目,
  • 更新了anaconda conda等

没有工作。当我选择PyCharm作为项目解释器时,为什么PyCharm会显示python版本为3.6,但是在inspection中却为3.5?

时间:

Settings- > Editor- > Inspections . 在python

这使你可以选择检查代码的Python版本。

  • 按Ctrl Alt S或者 Command Option S打开设置
  • Settings > Editor > Inspections > Python | Code compatibility inspection >(在我的情况下是3.7和3.8,然后是2.7),
  • Settings > Project : | Project Interpreter > 确保选择了正确的版本和解释器,
  • File > Invalidate Caches / Restart
  • 完成。

...