others - 解析dependencies错误:读取 org grails plugin的工件描述符失败:ckeditor: zip: 3.6.6.1. 0

即使没有对BuildConfig.groovy进行更改,也经常出现这个问题。

我在BuildConfig的plugins部分有如下内容:


compile":weceem:1.2"

这与ckeditor- 3.6.6.1 .0相关,它产生错误:Resolve error obtaining dependencies : Failed to read artifact descriptor for org.grails.plugins:ckeditor:zip : 3.6.6.1 .0

我之前就处理过这个


compile":ckeditor:3.6.6.1.1"

但现在,即使引用ckeditor 3.6.6.1 .1,我仍然得到相同的错误。

以下是依赖项报告的输出:


|Configuring classpath
|Downloading: org/grails/plugins/ckeditor/3.6.6.1.0/ckeditor-3.6.6.1.0.pom
Error |
Resolve error obtaining dependencies: Failed to read artifact descriptor for org.grails.plugins:ckeditor:zip:3.6.6.1.0 (Use --stacktrace to see the full trace)
Error |
Resolve error obtaining dependencies: Failed to read artifact descriptor for org.grails.plugins:ckeditor:zip:3.6.6.1.0 (Use --stacktrace to see the full trace)
Error |
Resolve error obtaining dependencies: Failed to read artifact descriptor for org.grails.plugins:ckeditor:zip:3.6.6.1.0 (Use --stacktrace to see the full trace)
Error |
Resolve error obtaining dependencies: Failed to read artifact descriptor for org.grails.plugins:ckeditor:zip:3.6.6.1.0 (Use --stacktrace to see the full trace)
Error |
Failed to read artifact descriptor for org.grails.plugins:ckeditor:zip:3.6.6.1.0
|Run 'grails dependency-report' for further information.
Error |
Failed to read artifact descriptor for org.grails.plugins:ckeditor:zip:3.6.6.1.0
|Run 'grails dependency-report' for further information.
Error |
Failed to read artifact descriptor for org.grails.plugins:ckeditor:zip:3.6.6.1.0
|Run 'grails dependency-report' for further information.
Error |
Failed to read artifact descriptor for org.grails.plugins:ckeditor:zip:3.6.6.1.0
|Run 'grails dependency-report' for further information.
Error |
SLF4J: Failed to load class"org.slf4j.impl.StaticLoggerBinder".
Error |
SLF4J: Defaulting to no-operation (NOP) logger implementation
Error |
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
.
|Environment set to development
.
build - Dependencies for the build system only (total: 33)
+--- xalan:serializer:2.7.1
+--- org.grails:grails-bootstrap:2.3.7
| --- org.slf4j:jcl-over-slf4j:1.7.5
| --- org.slf4j:slf4j-api:1.7.5
| --- org.apache.ant:ant:1.8.4
| --- jline:jline:2.11
| --- org.apache.ant:ant-launcher:1.8.4
| --- org.apache.ant:ant-trax:1.7.1
| --- net.java.dev.jna:jna:4.0.0
| --- org.apache.ant:ant-junit:1.8.4
| --- org.codehaus.gant:gant_groovy1.8:1.9.6
| --- org.apache.ivy:ivy:2.3.0
| --- org.fusesource.jansi:jansi:1.11
+--- org.grails:grails-scripts:2.3.7
| --- org.spockframework:spock-core:0.7-groovy-2.0
| --- org.hamcrest:hamcrest-core:1.3
| --- junit:junit:4.11
+--- org.grails:grails-docs:2.3.7
| --- org.xhtmlrenderer:core-renderer:R8
| --- org.yaml:snakeyaml:1.8
| --- org.grails:grails-gdoc-engine:1.0.1
| --- com.lowagie:itext:2.0.8
| --- bouncycastle:bcmail-jdk14:138
| --- bouncycastle:bcprov-jdk14:138
| --- commons-lang:commons-lang:2.6
+--- org.grails.plugins:tomcat:7.0.52.1
| --- org.apache.tomcat:tomcat-catalina-ant:7.0.52
| --- org.apache.tomcat.embed:tomcat-embed-jasper:7.0.52
| --- org.apache.tomcat.embed:tomcat-embed-el:7.0.52
| --- org.apache.tomcat.embed:tomcat-embed-logging-log4j:7.0.52
| --- org.apache.tomcat.embed:tomcat-embed-websocket:7.0.52
| --- org.eclipse.jdt.core.compiler:ecj:3.7.2
| --- org.apache.tomcat.embed:tomcat-embed-core:7.0.52


|Downloading: org/grails/plugins/ckeditor/3.6.6.1.0/ckeditor-3.6.6.1.0.pom
Error |
Error executing script DependencyReport: org.eclipse.aether.collection.DependencyCollectionException: Failed to collect dependencies at org.grails.plugins:weceem:zip:1.2 -> org.grails.plugins:ckeditor:zip:3.6.6.1.0 (Use --stacktrace to see the full trace)

时间:

尝试使用最新版本的Weceem:weceem-1.3-M1,还要注意,在BuildConfig.groovy中,我们需要额外的存储库

mavenRepo http://repo.grails.org/grails/core"

在最新版本中,用插件ckeditor- 4.4.1.0

...