others - 在Java for Elasticsearch 7.4.2 Java高级REST客户端中,如何创建一个IndexRequest?

我的pom.xml有以下依赖项:


 <dependencies>


 <dependency>


 <groupId>org.elasticsearch.client</groupId>


 <artifactId>elasticsearch-rest-high-level-client</artifactId>


 <version>7.4.2</version>


 </dependency>



 <!-- https://mvnrepository.com/artifact/org.slf4j/slf4j-simple -->


 <dependency>


 <groupId>org.slf4j</groupId>


 <artifactId>slf4j-simple</artifactId>


 <version>1.7.25</version>


 </dependency>



 </dependencies>



我也尝试将下面的依赖项添加到pom.xml


<dependency>


 <groupId>org.elasticsearch</groupId>


 <artifactId>elasticsearch</artifactId>


 <version>7.4.2</version>


 </dependency>



时间: 原作者:

你可以在pom.xml中更改ES客户端版本。

请参见com.indore.GalaxyApp#createIndex方法,创建IndexRequest。

原作者:
...