others - python 分布式 1.21.8需要 msgpack,但它未安装

我在尝试安装plotly时遇到问题,我使用Debian 9上的命令行升级anaconda,收到错误消息 "distributed 1.21.0 requires msgpack, which is not installed".

然后我尝试了conda install mspack,然后,pip install --upgade plotly,我得到"distributed 1.22.0 requires msgpack, which is not installed".这个错误消息是我在许多软件包升级过程中引发的。

pip install msgpack没有解决这个问题

时间:

安装dask时,我遇到了同样的问题,我使用以下两种方法之一来解决它。

第一个方法:运行命令


conda install -c anaconda msgpack-python



第二个方法:运行命令


pip install msgpack



以管理员身份运行Anaconda提示符,并输入以下内容:


pip install msgpack



回答你的问题

" 1.21.8 requires msgpack"这里错误与plotly安装无关。 这是因为巨蟒安装的方式

错误不会影响任何软件包的安装/升级。

"安装 msgpack does无法修复"在尝试使用用户管理安装msgpack之前,. It 将不会修复( Windows )/root ( linux ) 右侧的问题。 我在 Windows 10 & Lubuntu 16上修复了上述解决方案

我安装了用于文本分类的TextBlob软件包,然后我尝试打开Jupyter Notebook ,得到了这个错误消息:AttributeError: type object 'IOLoop' has no attribute 'initialized'
然后意识到distributed 1.22.0 requires msgpack, which is not installed.安装后msgpack问题解决了。

...