others - 我应该如何命名只有一个getter的Java类?

例如:


public interface ValueRetriever


{


 double retrieveValue();


}



以下是两个实现:


public class TotalMemoryRetriever implements ValueRetriever


{


 @Override


 public double retrieveValue()


 {


 return Runtime.getRuntime().totalMemory();


 }


}



public class FreeMemoryRetriever implements ValueRetriever


{


 @Override


 public double retrieveValue()


 {


 return Runtime.getRuntime().freeMemory();


 }


}



我选择了"retriever",但是有没有更好的方法?这里有最佳实践或其他惯例?

时间:

你可以命名类TotalMemorySensor和FreeMemorySensor,并使用它们实现MemorySensor接口。

我不确定是否应该对RAM,CPU,磁盘和其他统计信息使用相同的接口,retrieve double是什么意思? 是KB,MB,GB? 它感觉DiskSensor应该有long totalSpaceInBytes(),而CpuSensor应该有double loadAverage(TimeUnit)

ValueRetriever已经有了DoubleSupplier。

...