apache - Spark 1.0.1安装错误

  显示原文与译文双语对照的内容

我在 spark 1.0.1安装 [EMR ] 上一直遇到这个错误

Hadoop版本:2.2 Spark: 1.0.1

错误

14/10/21 06: 58: 11警告 util.NativeCodeLoader: java.library.path java.lang. UnsatisfiedLinkError中没有 hadoop: java.library.path 中没有 hadoop

我像这样尝试,但它仍然失败。

/spark外壳程序 -Djava.library.path=/home/hadoop/share/hadoop/common

任何建议都非常感谢你。

时间: 作者:

请不要担心这里警告。 你可以忽略它。 如果你觉得不符合它,你可以把 java.library.path 指向 $HADOOP_HOME/lib/native

我怀疑这个问题是由于电子病历的早期构建。 请按照 https://github.com/awslabs/emr-bootstrap-actions/tree/master/spark 描述的最新版本尝试,因为安装和版本自 1.0.1以来已经得到了极大的改进。

...